Teme: Mikrotik

Mikrotik i SysLog for Windows server

Skraćena veza: http://pedja.supurovic.net/veza/7051

Mikrotik kao i svaki drugi ruter može da loguje mnogo informacija. Međutim, pregled njegovog loga je nepraktičan, veoma ograničen,

Ako vam je potrebno da imate bolju analizu logova, neophodno je da logove beležite van mikrotik rutera. Za to se upotrebljavaju syslog serveri.

Prirodna radna platforma za syslog server je linuks operativni sitem. Ako ste orijentisani na vindouz, izbor je veoma sužen.

Sasvim korektan syslog server za vindous je Syslog for Windows. Program je besplatan i otvorenog koda. Radi kao vindouz servis.

Instalacija ovog programa je više nego jednostavna: preuzmete instalaciju, pokrenete je i kada se instalacioni program zatvori, syslog server je pokrenut i u principu ništa na njemu više ne morate da dirate.

Sada je potrebno da podesite mikrotik ruter. To se radi iz dva koraka. Najpre treba da podesimo loging akciju koja će slati podatke na syslog server.

/system logging action add name=syslog \
 target=remote remote=10.10.10.7  remote-port=514 \
 bsd-syslog=yes syslog-facility=daemon \
 syslog-severity=notice

Parametri su:

name – naziv akcije
target – odredište log podataka, nama treba remote
remote – IP adresa syslog servera
remote-port – port na kome sluša syslog server, podrazumevano je 514
bsd-syslog – da li se upisuje log prema standardu RFC 3164
syslog-facility – Oblast kojoj blog poruka pripada
syslog-severity – nivo važnosti poruke

Ako menjate vrednosti syslog-facility i syslog-severity proverite u podešavanjima servera da li đe podešenu kombinaciju prihvatiti.

Nakon ovoga potrebno je još samo da podesimo da se određeni log podaci šalju preko ovako podešene akcije:

/system logging add topics=web-proxy action=syslog

Parametri su:

topics – izbor podataka koji se loguju
action – koja akcija se izvršava, u našem slušaju podešavamo akciju koju smo prethodno napravili pod imenom syslog.

Ovim će svaki log zapis koji se odnosi na veb proksi biti usmeren na syslog server.

Na syslog serveru i direktorijumu log/ koji se nalazi u direktorijumu gde je server instaliran (\Program Files\syslog\) se nalaze log datoteke u koje će že biti upisani podaci. To su tekstualne datoteke koje je lako analizirati.


Podelite ovaj članak sa prijateljima


1 comment to Mikrotik i SysLog for Windows server

  • Mile-Lile

    Jedina mana je što komp troši struju ako radi 24h. Ja sam, pretražujući internet, naišao na jedno simpatično rešenje https://papertrailapp.com/
    Besplatna je registracija imate mogućnost do 100 MB da poašljete podataka što je za kuću ili neku malu firmu više nego dovoljno. Podatke možete gledati u realnom vremenu sa bilo koje lokacije koja ima pristup internetu. Nebitno da li je IP dinamička ili statička. Mana je što podaci koji se šalju nisu enkriptovani. Ali ako syslogd koristite za troubleshooting nije problem…

Leave a Reply

 

 

 

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Popunite izraz tako da bude tačan: *