Teme: Mikrotik

Mikrotik: kontrola protoka (QoS) i prioriteta konekcija

Skraćena veza: http://pedja.supurovic.net/veza/1691

Jedna od češćih pitanja vezanih za podešavanje Mikrotika se odnose na kontrolu protoka. Mikrotik važi za jedno od najjeftinijih rešenja za kvalitetnu kontrolu protoka ali nije baš jednostavan za podešavanje.

U najjednostavnijem slučaju upotrebićete Simple Queues i najčešće je to sasvim dovoljno. Kako se koristi Simple Queues možete pročitati u uputstvu http://wireless.uzice.net/uputstva/mikrotik-osnovno-podesavanje-deljenje-internet-konekcije/

Međutim, ako vam jepotrebno iole komplikovanija kontrola protoka, davanje prioriteta određenim vrstama knekcija, a ograničavanje drugih, tu već ima mnogo više posla i potrebno je Mikrotik poznavati mnogo ozbiljnije.

Na nedavno održanom MUM, Janis Megis (Janis Megis) iz Mikrotika je održao predavanje baš na ovu temu kojim je pokrio u osnovnim crtama uglavnom sve što je potrebno znati. Predavanje je snimljeno tako da ga možete pogledati.

Uz video snimak poslužiće vam i PDF sa slajdovima sa predavanja.

Predavanje samo treba da vam posluži kao uvod, jer ćete ipak morati da pročitate još mnogo toga da biste ovladali Mikrotikom na ovaj način.


Podelite ovaj članak sa prijateljima


27 comments to Mikrotik: kontrola protoka (QoS) i prioriteta konekcija

  • Nedim

    Pozdrav,
    Vas odlican tekst mi je puno pomogao pri osposobljavanju PC kao mikrotik rutera. Imam pitanje. Naime, M-Tik router se na net spaja preko Access pointa na ISP. M-Tik je podesen na NAT (masquerade) i iza njega se nalaze tri PC-a. Prema Vasem uputstvu, podesio sam Simple Queue ali me zanima zasto M-Tik, kada od onih tri klijent PC-a dvojica ne koriste net (bar ne puno), usporava treci klijent PC umjesto da mu dodijeli puni (neiskoristeni) protok. Brzina interneta je 512/192 Kbps, PC-1 ima limit na 384/128 kbps i max limit na 2048 Kbps sa prioritetom na 1 a druga dva imaju po 256/80 kbps limit i max limit na 384/128 kbps sa prioritetom na 2. Srdacan pozdrav

  • Prva stvar, ako ti je brzina internet linka 512 kbps, onda nema nikakve svrhe da računarima u lokalnoj mreži ograničavaš brzinu na 2048 kbps jer tu brzinu niko ne može dapostigne.

    max-limit ne treba da bude veći od maksimalne brzine internet protoka koja je moguća. Kome želiš da dozvoliš da povuče maksimalan protok preko internet linka koji imaš, namesti mu max-limit na 512 kbps.

    Suprotno tome, upotrebi limit-at da podesiš garantovanu brzinu. Ova brzina treba da bude manja od brzine internet linka, podešena tako da je moguće da svi korisnici dobiju tu garantovanu brzinu i kada svi odjednom vuku protok s ainternet linka. U tvom slučaju sa tri računara u lokalnoj mreži koji dele internet protok, to bi trebalo da bude 170 kbps.

    Kao što je u ovom a i drugim člancima rečeno, kada preopteretiš link, onda zaboravi na ograničenje protoka. To radi samo ako postoje slobodni resursi na linku da se može raditi deljenje. Onog momenta kada računari koji dele internet protok teže da povuku zajedno više nego što internet link može da pruži sva pravila deljenja protoka padaju u vodu.

    Pogledaj članak http://wireless.uzice.net/uputstva/mikrotik-osnovno-podesavanje-deljenje-internet-konekcije/ koji se ovim detaljnije bavi.

  • Nedim

    Pozdrav,
    Veliko hvala na brzoj replici.
    Tih 2048kbps sam za PC-1 stavio jer ponekad se desi da internet link malo preskoci limit od 512kbps, vjerovatno zbog smanjenog opterecenja kod ISP-a. Iako je ne moze postici, htio sam da natjeram M-tik da, kada su druga dva PC-a ugasena, prvom dodijeli sav raspolozivi protok i da ga smanji na limit samo ukoliko se ukljuci neki od druga dva PC-a.
    Znaci, moje pitanje bi se moglo i ovako preformulisati. Ukoliko za PC-1 postavim samo CIR (limit-at) limit a MIR (max-limit) izostavim, hoce li on biti zakljucana na CIR limit bez obzira na opterecenje linka tj. hoce li mu, ukoliko je to moguce, dodijeliti kompletan protok? (tj. da posudi trenutno nekoristeni protok rezervisan za druge.)

    Drugo, kako da podesim prioritete raznim protokolima – konkretno za p2p. Htio bih da mi ne usporava bit-torrent. Mislim da mi M-Tik ogranicava broj peerova a ne znam kako da to iskljucim. Koristim bit-torrent i bitno mi je da radi max mogucom brzinom.

    Veliki pozdrav,
    Nedim

  • Kao što rekoh, limit-at je garantovani protok. Mikrotik će se truditi da korsiniku obezbedi bar toliki protok sve dok je to moguće. max-limit je maksimalan protok, Mikrotik će korisniku dozvoljavati najviše toliki protok. Ako max-limit nije podešen, onda će Mikrotik korisniku pružiti sve što može.

    Ograničenja protoka funkcionišu samo dok link nije preopterećen, drugim rečima, Mikrotik će pokušavati da korsinicima obezbedi garantovani protok sve dok ima dovoljno protoka da svi budu zadovoljeni.

    Što se tiče prioriteta za protokole, jesi li ti uopšte pogledao ovaj video zapis zbog koda sam napisao ovaj čalank. On je odgovor na tvoje pitanje. Doduše, on odgovara i na pitanja vezana za ograničenje protoka, kao i članak za koji sam ti ostavio link. Ne očekuješ da moram da ti ih prepričavam?

  • Ljubek

    Imam mrežu od dvadesetak korisnika (windows Xp Workgroup) i Adsl nalog od telekoma 3 Mbit. ADSL modem je spojen na mikrotik (Pentium 3 sa Mikrotik OS 3.2 Level 5). Izlaz sa druge mrežne karte je spojen na svič i dalje do svakog računara.Sve je podešeno i radi korektno prema Vašem uputstvu:
    http://wireless.uzice.net/uputstva/m…net-konekcije/
    Zanima me ako hoću da za sebe uzmem 1Mbit protoka a za ostale da se deli na ravne časti (svi imaju pristup netu) da li komanda izgleda ovako:

    /queue simple add name=“Moj PC“ dst-address=192.168.1.11/32
    interface=wan direction=both priority=8 queue=default/default
    limit-at=32000/32000 max-limit=1000000/1000000 disabled=no
    (za moj računar)

    I za ostale:

    /queue simple add name=“ostali“ dst-address=0.0.0.0/0
    interface=wan direction=both priority=8 queue=default/default
    limit-at=32000/32000 max-limit=64000/64000 disabled=no

    Kada ovako podesim parametre dolazi do odličnog rada mreže i Interneta na svim računarima (barem sam gledao desetak njih) nekih pola sata a onda iz (meni) neobjašnjivih razloga dolazi do gušenja i potpunog prestanka rada Interneta na svim računarima???

  • Na simple queue za tvoj racunar stavi limit-at na 1 mbit i tebi će biti garantovana brzina od 1 mbit.

    Dodaj još jedan simple queue (nazovi ga na primer korisnici) kome ćeš staviti max-limit na 2 megabita (bolje je nešto manje) a onda za svakog korisnika novi simple queue kome ćeš staviti da je simple queue koji se zove korisnici roditelj (parent), tako da možeš svakom pojedinačno dodatno da regulišeš brzinu po potrebi, ali da svi zajedno ne mogu preći 2 mbita.

    Uvek računaj sa tim da ograničennje protoka radi samo dok ima dovoljno protoka za sve, onog momenta kada korisnici pokušaju da povuku više nego što internet link može da da, nema garancija da će ograničenje protoka raditi kako treba.

  • Ljubek

    Hvala na brzom odgovoru, pokušaću kao što si rekao.
    Inače može li ovako da se po svakoj IP adresi dodijeli protok za recimo 128/64K:

    /queue simple add name=“Klijent 1-n“ target-addresses=ip_klijenta_1-n/32 dst-address=0.0.0.0/0 interface=all parent=none priority=8 queue=default/default limit-at=64000/128000 max-limit=64000/128000 burst-limit=64000/256000 burst-threshold=64000/128000 burst-time=10s/10s total-queue=default

    Pozdrav

    • Ako si to hteo – može, samo smanji burst-treshold jer će ti tako kako si namestio svakih 10 sekundi uključivati privremeno povećanje brzine. Smanji to na recimo 100000.

  • umrezavanje racunara

    E dopada mi se clanak, bas sam se namucio oko podesavanja prvi put. Steta sto nisam tada izguglao ovo. Nadam se da ce pocetnicima biti od koristi. Pozdrav

  • Vlada

    Pozdrav pedja. Imam nekoliko pitanja.

    Posedujem neku pentium 2 i planiram da kupim mikrotik softver i da uradim sledece ako je moguce.

    E ovako sam ja zamislio.

    ADSL modem –> mikrotik(u njemu 3 LAN kartice i jedna WLAN,preko jedne lan kartice dobijam net,a preko druge dve dajem net za 2 racunara u kuci,a WLAN –> Omni antena na koju se kace ljudi oko mene)

    Zanima me da li je ovo moguce ostvariti?

    Imam neki wireless pojacivac(1000mW).Da li ce on pomoci
    da dalje bacim signal,npr za neke ljude koji su udaljeni od moje kuce 1km do 3km?

    • Može to što si zamislio, samo ti ne trebaju dve lan kartice za po kući. Dovonjna je jedna a na nju zakači svič pa razvodi koliko hoćeš.

      Što se tiče pojačavača, baci ga. Ne treba ti, samo ćeš da praviš sa njim probleme i sebi i drugima, a i protivzakonito je njihovo korišćenje.

      Svi problemi sa dometom se uvek i isključivo rešavaju antenama.

  • Vlada

    imam jos jedno pitanje.

    Da li ja smem da prodajem internet bez registrovanja „firme“?4
    Jel postoji neki zakon u vezi toga?
    Kod mene u selu ima jedna wireless mreza i svi se zale
    i ja sam dosao na ideju da im ucinim dobro,plus da neki
    dinar zaradim.Koliko znam ni ta mreza nije registrovana.

  • Da bi se bavio internet provajdingom moraš registrovati firmu odgovarajuće delatnosti i registrovati se kao internet provajder kod RATEL-a. Bez toga, dovoljna je samo jedna prijava da ti sve što si uložio propadne.

    Uz to ne smeš preprodavati link koji si uzeo od internet provajdera bez njegove saglasnosti.

  • Vedran

    Postovani Pedja,
    Radim seminarski rad na temu „Metode kontrole toka i zagusenja na MikroTIK ruteru“. Pregledao samo detaljno Vasu stranicu i vidio sam da ste strucnjak u toj oblasti. Zelio bih Vas zamoliti da mi pomognete sta bi tacno trebao uraditi u ovoj temi i neke eventualne literature koja ima obradjenu tu temu. Asistent koji mi je davao zadatak rekao je da je naglasak na prakticnome radu.
    Hvala Vam mnogo unaprijed i srdacni pozdravi iz snijeznog Sarajeva.

    • Uh, to je prilično kompleksna tema. Mogu ti sdati samo neke neke ideje šta treba da istražiš:

      - ograničenje protoka – izdvojena konekcija se ograničava tako da ne može daoptereti link više od dozvoljenog. Protok može biti garantovan i negarantovan.

      - davanje različitog prioriteta konekcijama – u slučaju zagušenja, konekcija sa većim prioritetom ima prednost

      - ograničavanje broja konekcija – ukoliko određeni izvor ima više konekcija nego što mu je dozvoljeno, nove konekcije mu nisu dozvoljene

      - raspršivanje konekcija preko više ruta – između dve tačke može postojati više ruta, pa se konekcije raspoređuju po svima njima kako bi se svaka pojedinačno rasteretila

      Što se tiče literature, jedini izvori su mikrotik uputstvo, mikrotik forum i poneki sajt sa tutorijalima, kao što je ovaj moj.

  • Vedran

    A da li biste nam mogli objasniti kako napraviti prakticnu mrezu u kojoj bi mogli testirati te metode kontrole toka i zagusenja??

  • Potreban vam je jedan mikrotik kao ruter na kome ćete raditi podešavanja. Najedan interfejs spojte svič i nekoliko računara koji će simulirati klijente a na druga dva interfejsa bi trebalo da dovedete internet linkove da biste imali mogućnost simulacije raspodele na više linkova.

    Ako nemate višelinkova onda možete upotrebiti još jedan mikrotik na kome ćete dva interfejsa spojiti sa testnim mikrotikom pa će on da vam simulira internet likove. na ovaj mikrotik na treći interfejs stavite jedan računar koji će simulirati internet.

    Za testiranje koristite program Bandwidth Test. Postavite ga na sve računare i njime možete simulirati različite brzine protoka kao opterećenje. Nemam ideju sa čim biste mogli simulirati veliki broj jednovremenih konekcija. možda ćete morati da napišete neki program koji će vam to raditi.

  • Steva

    pozdrav
    mene interesuje kako da zabranim pristum svima koji adresu kucaju rucno
    odnosno da dozvolim samo onima koji dobiju adresu od DHCP servera i to ako je moguce samo nda kad ja kazem u DHCP LEASES da je adresa static i zavedem je u simple queue ili tako nekako, da niko ne moze da se nakaci na lan bez dozvole.

  • Na mrežnom interejsu poresiš ARP reply-only a u DHCP serveru uključiš Add ARP For Leases.

  • Steva

    za rucno dodavanje adresa je ok
    jos samo kako da resim da nemaju pristup netu ni adrese koje je DHCp server dodelio i jos su dinamicke odnosno da ga ja vidim u DHCP LEASES
    i zavedem ga kao static i tek onda da ima pristum netu ili tako nekako :)

  • Najjednostavnije je da grupišeš IP adrese, na primer statične dodljuj u opsegu 192.168.1.100 do 192.168.1.200 a dinamičke od 192.168.1.200 do 192.168.1.50. U fajervolu ćeš tada moći da za svaku grupu podesiš željena pravila.

  • Daky

    Pozdrav! Hteo bih da pitam kako bih mogao da od vise mikrotika i antena tj predajnika napravim bridg da sve to ide na jedan glavni mikrotik i tamo da limitiram protok,a ne na svakom posebno,znaci svi korisnici da budu na jednom mikrotiku (routerboard 1200), a ostali sistemi tj vise mikrotika na vise mesta da rade kao link tj samo da prenesu konekciju korisnika do glavnog mikrotika u glavnom mikrotiku je ukljucen opticki kabal, ako je to moguce, i kako? :)

    Pozz!

    • Zavisi šta hoćešp da uradiš.

      Ako ti je cilj da kontrolišeš protok koji korsinici prave preko internet linka onda to ionako sve terba da radiš na ruteru koji je direktno povezan na internet link a svejedno je kakva je konfiguracija lokalne mreže.

      Ako želiš da ograničiš protoke i unutar mreže, dakle, između korisnika, onda treba da napraviš da se korisnici povezuju preko VPN (obično PPPoE) i tako možeš na jednom mestu da im otvaraš naloga i podešavaš koliko ko može da ima protoka.

      Najlakše jeste da sve spojiš u bridž ali je ti i lošije rešenje. Bolje je da koristiš radijus server.

  • Daky

    hvala na odg! A kazi mi kako mogu da izbegnem opadanje protoka kroz tri bazne stanice na trecoj baznoj stanici 3 puta opao protok,nije bridzovano nego natovano.. mikrotikovi su natovani.. ? :)

  • Steva

    pozdrav
    imam problem u Simple Queues, nece da meri trenutni protok kad je Download/upload na unlimited, odnosno cim stavim neki limit on pocne da meri protok saobracaja, gde gresim kako da to resim.
    hvala

Leave a Reply

 

 

 

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>


− pet = 2