Mikrotik skript: čuvanje statistike protoka u tekst datoteci

Skraćena veza: http://pedja.supurovic.net/veza/5245

Evo jednostavnog primera koji demonistrira upotrebu mikrotik skript jezika za čitanje podataka iz Simple Queue u petlji i njihov zapis u tekstualnu datoteku:

{

 :local mOutput ""

 :foreach mQueue in=[ /queue simple find] do={  

   :local mName [get $mQueue name]
   :local mSaveStat [:find $mName "%"] 

   :if ($mSaveStat >= 0)  do={
     :local mBytes [get $mQueue bytes]
     /queue simple reset-counters $mQueue
     :set mOutput ( $mOutput . $mName . ":" . $mBytes  . "\n")
     :put ($mOutput)
   }

 }

 /file print file=wan-stats
 /file set wan-stats.txt contents="$mOutput"

}

Kroz listu Simple Queue pravila se prolazi petljom foreach. Za svako pravilo se izvršava kod u do bloku petlje. […]
[ ... vidi ceo članak ... ]

Kako da onemogućite da neko drugi vaš sajt prikazuje u iframe

Skraćena veza: http://pedja.supurovic.net/veza/4597

Primetio sam da jedan sajt koji između ostalog ima i funkciju blog agregatora prikuplja i prikazuje moje članke. Generalno, nemam ništa protiv blog agregatora, uostalom to im je i svrha, ali sam primetio da ovaj agregator to radi na način koji smatram nekorektnim: sadržaj članaka sa mog bloga učitava sa mog bloga ali u okviru <iframe> taga.

Time agregator postiže da se moj blog prikazuje u okviru strane koju on potpuno kontroliše: postavlja reklame, referale, linkove ka socijalnim mrežama, pa čak i Gulg analitici prikazuje te strane kao svoje i tako u stvari grabi sebi gugl rejting. Povrh svega on i dalje troši moje resurse, jer se prikazuje sadržaj koji je učitan sa mog servera. […]
[ ... vidi ceo članak ... ]

Koliko je siguran PHP na vašem veb serveru?

Skraćena veza: http://pedja.supurovic.net/veza/2360

Prilikom izrade sajtova, ono o čemu se često najmanje misli je sigurnost servera. Nažalost, vrlo je lako u PHP-u napraviti neku rupu preko koje napadač može da zloupotrebi sajt, odnosno server na kome je on postavljen.

Najvažnije je da je sam server podešen tako da je upad otežan ili onemogućen. Kako postoji mnogo načina da se upad izvede teško je sve to pratiti i proveravati.

U nastojanju da se posao provere olakša, PHP Security Consortium je objavio PHP skript PhpSecInfo koji proverava kako je sam PHP podešen i upozorava na moguće slabosti. Skript se koristi na sličan način kao i PHP funkcija phpinfo(). […]
[ ... vidi ceo članak ... ]