Teme: Mikrotik | Umrežavanje

TP-Link TL-SG2109WEB, VLAN i Mikrotik

Skraćena veza: http://pedja.supurovic.net/veza/5148

U nastojanju da malo sredim mrežu i šumu kablova odlučio sam da primenim VLAN. Za tu svrhu sam uzeo upravljivi svič TP-Link TL-SG2109WEB. On ima 8 gigabitnih portova što je moralo da mi bude dovoljno, s obzirom da su svičevi sa većim brojem portova značajno skuplji.

Instalacija koju sam zamislio da ostvarim je sledeća:

Imam tri intenet linka koje sve želom da jednim kablom spojim na Mikrotik. Stoga ću napraviti tri VLAN-a (VLAN1, VLAN2 i VLAN3) koje ću spojiti u jedan trank (TRUNK). U Mikrotiku ću napraviti tri VLAN interfejsa na fizičkom WAN interfejsu i oni će mi služiti za podešavanje konekcija za linkove.

Preostala četiri porta na sviču ću spojiti u VLAN9. Oni će služiti za lokalnu mrežu. Naknadno planiram da i njih podelim na VLAN-ove da bih segmentirao lokalnu mrežu, ali to ostaje za drugu priliku. Mikrotikov LAN interfejs ću spojiti na port 8 i tako će on biti u VLAN9.

Podešavanje VLAN-ova

Iako ovaj moj plan nije ništa posebno zahtevan, odnosno korsiti VLAN-ove na uobičajeni način, pokazalo se da to ipak nije tako jednostavno podesiti. U stvari, najveći problem je bio u tome što je dokumentacija sviča TL-SG2109WEB prilično oskudna, a logika koja je primenjena se razlikuje od onoga što bi neko naviknut na skuplje uređaje poznatijih firmi očekivao. Ja doduše ne spadam u zakve poznavaoce ali sve što sam od literature nalazio, odnosilo se na CISCO i sličnu opremu, što mi je samo dodatno otežavalo. Ipak sam uspeo nekako da se snađem.

Podešavanje VLAN9 je najjednostavnije. TL-SG2109WEB se može koristiti u režimu kada se  VLAN-ova i prosto dodele portovima (Port VLAN (Port-based VLAN)) i to je sve. Svič forsirano dodeljuje VLAN ID svakom paketu koji dođe na taj port.

No, ja to nisam mogao tako da uradim, jer mi je bilo potrebno i da rešim VLAN1, VLAN2 i VLAN3 sa trunk portom. U podešavanjima sviča postoji opcija za podešavanje trankova ali se ispostavilo da to uopšte nisu trankovi kako se to uobičajeno definiše u VLAN terminologiji te mi to nije pomoglo. Najzad, sam utvrdio da ću stvar moći da rešim izborom režima VLAN tagovanja:

Sledeći korak je dodela VLAN-ova portovima. Izabere se opcija Tag VLAN Global Setting i svakom portu se upiše kom VLAN-u pripada:

Portovima 1 i 2 sam dodelio VLAN1, portu 3 VLAN2, portu 4 VLAN3, a preostalim portovima VLAN9. Port 1 će služiti kao trank za VLAN1, VLAN2 i  VLAN3, ali neće smetati što mu je dodeljen VLAN1. Port SFP neću koristiti ali sam mu ipak dodelio VLAN9 pošto neki VLAN mora da mu bude dodeljen.

Podešavanje se dovršava u opciji Tag VLAN Setting kojom se konačno određuje kako će paketi biti tagovani. Prvo sam podesio VLAN9 je to najjednostavnije podešavanje tako da obezbedim da ću imati funkcionalne portove na sviču pre nego što počnem podešavanje tranka. To je bitno, jer greška u podešavanju lako može dovesti do toga da svič ostane nedostupan, te da ga morate resetovati na fabričke vrednosti i sve raditi iz početka.

Za VLAN sam izabrao 9 pa je svič pokazao podešavanja tagovanja za taj VLAN. U Polju VLAN ID treba da stoji 9. Dalje, u koloni Member treba označiti samo one portove kojima je zaista dodeljen VLAN9 i njima u koloni Egress Frame treba podesiti vrednost Drop Tag.

To znači da na ove portove povezujemo samo uređaje koji ne dodeljuju VLAN tagove paketima. Ako ih slučajno neko i dodeli, te oznake će svič obrisati a umesto njih će dodeliti oznaku VLAN-a koji je tom portu dodeljen u opciji Tag VLAN Global Setting.

Sada prelazim na podešavanje VLAN1. On je dodeljen portu 1  iportu 2. Pri tom, port 1 će služiti kao trank. Trank port je specijalan port koji propušta pakete koji već sadrže VLAN oznake. Jedino kroz ovaj port mogu da proću paketi sa različitim VLAN oznakama. Kroz običan port prolaz esamo paketi koji sadrže oznaku VLAN-a koji je portu dodeljen.Na trank port se povezuju uređaji koji označavaju pakete. To može biti neki drugi svič ili ruter. U mom slučaju to je Mikrotik ruter.

Podešavanje tranka izgleda ovako:

Odabrao sam VLAN1 za podešavanje, i isključio sve portove osim portova 1 i 2 koji spadaju u ovaj VLAN. Port 2 će služiti da se na njega zakači internet link, dakle, tu treba forsirati oznaku VLAN-a. Za taj port ćemo podesiti opciju Drop Tag. Port 1 će služiti kao trank, dakle on treba da propušta označene pakete kao i da na odgovarajući način označava odlazne pakete, zavisno od VLAN-a sa koga su ti paketi došli. Zato ću ovom portu podesiti opciju Add Tag.

Od sada svaki paket koji dođe na port 1 a sadrži oznaku VLAN2 biće prosleđen na port 2 i obrnuto, svaki paket koji dođe na port 2 biće označen kao VLAN2 i prosleđen na port 1.

Podešavanje VLAN2 i VLAN3 je slično. Razlika je samo u tome što se za VLAN2 umesto porta 2 koristi port3, a za VLAN3 port 4, a i ovim dvama VLAN-ovima se obavezno dodeljuje port 1 jer je on trank za njih.

Podešavanje možemo na brzinu proveriti klikom na dugme All VLAN koje će prikazati kako su VLAN-ovi dodeljeni:

Podešavanje Mikrotika

Mikrotik podržava VLAN-ove i njihovo podešavanje je jednostavno. Interfejs WAN je fizički, kablom, spojen sa svičem na port 1 koji je trank. VLAN-ove u Mikrotiku definišemo na ovom interfejsu komandama:

/interface vlan
add name=vlan1 vlan-id=1 interface=wan
add name=vlan2 vlan-id=2 interface=wan
add name=vlan3 vlan-id=3 interface=wan

Parametar vlan-id odgovara oznaci VLAN-a koju smo odredili u sviču. Ovim komandama smo definisali tri VLAN-a sa oznakama 1, 2 i 3.

Kako sve ovo sa VLAN-ovima radi?

VLAN ID je četvorobajtna oznaka koja se upisuje u zaglavlje svakog eternet paketa. Ona služi da se paketi raspoznaju po pripadnosti VLAN-ovima i tako usmeravaju.

Ako na primer paket sa konekcije ISP2 dođe na sviča, on će stići na port 3 jer je na njemu napravena fizička veza. Svič će primiti paket označiti ga kao VLAN3 i tatim ga proslediti na port 1 koji je trank. Na ovaj port je fizički povezan Mikrotik, svojim WAN interfejsom. Tako da će paket biti proslećen na taj interfejs. Kako su na WAN interfejs postavljeni VLAN intefejsi, Mikrotik će utvrditi kom interfejsu odgovara primljeni paket. U ovom slučaju to će biti interfejs vlan3. Kada paket stigne na njega dalje će biti obrađen kao svaki običan paket.

Slično će se desiti sa paketima sa preostale dva internet konekcije. Oni će stići na odgovarajuće VLAN interfejse u Mikrotiku i dalje biti obrađeni kao i obično.

U suprotnom smeru, ako u Mikrotiku treba da se pošalje paket preko nekog od VLAN interfejsa, njemu će biti upisana oznaka VLAN-a kome taj interfejs pripada. Tako označen paket će preko WAN interfejsa, fizičkom vezom, doći na port 1 sviča. Tu će biti prepoznata oznaka VLAN-a i paket će biti prosleđen na odgovarajući port, a odatle ka internet konekciji na koju je upućen.

Meni je ovakvo podešavanje omogućilo da sve tri internet konekcije proguram kroz jedan UTP kabal i tako značajno smanjim stalnu gužvu sa kablovima koje imam u stanu.


Reklama: ExeShop nudi veliki izbor TP-Link opreme


Podelite ovaj članak sa prijateljima


9 comments to TP-Link TL-SG2109WEB, VLAN i Mikrotik

  • Svaka čast na članku tj. uputstvu. Imao sam prilike nekoliko puta da se igram sa podešavanjima mikrotika, ali ne ovoliko komplikovano. Jedan net, jedan kabel -> mikrotik -> linux server sa 2 mrežne kartice (proxy, squid, dans guard itd.) -> linux server za podatke u firmi (komplikovana samba) -> nekoliko switcheva -> ~50 računara. To i dan danas sve funkcioniše.

  • Sasa, ovde se ne radi o Mikrotiku vec o TP-Linku. Inace uputstvo je super!

  • Aleksandar

    Čisto radi razmene ideja postavljam pitanje:
    Nije li fleksibilnije kao Mikrtotuk wired ruter
    koristiti RuterBoard 750(G)koji ima 5x100Mbps
    ili 5x1Gbps portova. Na njegova tri porta vezati:
    ISP1, ISP2 i ISP3? Sa četvrtog porta RouterBoarda
    750(G) se vratiti na switch. Tu vidim daleko fleksibilnije korišćenje veza ka Net-u, a na switchu ostaje više slobodnih portova za PC-je, kamere, NAS-ove. RouterBoard nije skup.

    Ako je osnovna ideja bila da se koristi samo postojeca
    oprema, bez kupovine nove opreme, i da se upotrebe VLAN-ovi
    onda je moje pitanje „promašilo“ temu.

  • Najpre, da, mreža je već bila postavljena i ovo je urađeno kao unapređenje.

    RB 750 mi ne odgovara iz više razloga, evo nekih:

    – najpre, za ruter prema Internetu više volim da stavim PC računar, jer ima dovoljno snage da svari sve moguća i nemoguća podešavanja za kontroluinternet linkova, ima mogucnost da se povežeće na modem pa čak i da se u njega stavi ISDN kartica, i vrlo bvvažno zbog logovanja – hard disk.

    – uvek za intrnet linkove koristim jedan ruter, koji se ne bavi unutrašnjim rutiranjem mreže. Tako su sva podešavanja znatno jednostavnija jer ruter ima samo jedan interfejs prema LAN-u. U mojoj mreži, na ovom upravljivom sviču, planiram da propustim jedno 4-5 subnetova. Na stranu što bi takvo podešavanja na RB u kombinaciji sa tri internt linka bilo komplikovano, RB 750 to ne bi mogao da podnese.

    – ruter mi se nalazi prilično udaljen od mesta gdes e nalaze intenet priključci, pa bi razvlačenje svih tih kablova bila prilična muka. Ovako sam broj kablova sveo na dva, jer kroz koji su propušteni VLAN-ovi za internet linkove i jedan koji je spojen na moj LAN.

  • rb600

    cek jel ti to nesto poput load balancing ,jel ti sva tri modema u jednom casu rade??? svaki modem po 1mb lupam izlaz ti je 3 mb ??/

    • Ne, VLAN-ovi su poslužili tome da kroz jedan kabal proturim tri nezavisna linka tako da ih mikrotik i dalje vidi kao tri mrežna interfejsa. Sa njima može da se radi sve što i sa fizičkim mrežnim interfejsima, pa i balansiranje protoka ako je to potrebno.

  • Postovani,

    Da li se cisco switch 3560g moze prikljuciti na 2
    opticka linka razlicitih internet provajdera ?

    Da li je moguce

    ip route 0.0.0.0 0.0.0.0 a.b.c.d
    ip route 0.0.0.0 0.0.0.0 x.y.z.w

    Pozdrav

Leave a Reply

 

 

 

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Popunite izraz tako da bude tačan: *