Изборник Затворити

Микротик скрипт: чување статистике протока у текст датотеци

Скраћена веза: https://pedja.supurovic.net/veza/5245

Ево једноставног примера који демонистрира употребу микротик скрипт језика за читање података из Simple Queue у петљи и њихов запис у текстуалну датотеку:

{

 :local mOutput ""

 :foreach mQueue in=[ /queue simple find] do={  

   :local mName [get $mQueue name]
   :local mSaveStat [:find $mName "%"] 

   :if ($mSaveStat >= 0)  do={
     :local mBytes [get $mQueue bytes]
     /queue simple reset-counters $mQueue
     :set mOutput ( $mOutput . $mName . ":" . $mBytes  . "\n")
     :put ($mOutput)
   }

 }

 /file print file=wan-stats
 /file set wan-stats.txt contents="$mOutput"

}

Кроз листу Simple Queue правила се пролази петљом foreach. За свако правило се извршава код у do блоку петље. […]
[ ... види цео чланак ... ]

Микротик: више јавних ИП на једном интерфејсу

Скраћена веза: https://pedja.supurovic.net/veza/5211

Недавно сам имао необичан случај мапирања портова за два сервера иза НАТ рутера. У локалној мрежи су подигнута два веб сервера, и требало је обезбедити да сваки од њих види са Интернета.

Са једним сервером је то лако, на мрежном интерфејсу на који долази интернет линк се подеси dst-nat порта tcp 80 ка серверу и то је готова ствар. Подешавање изгледа овако:

Интерфејсу додељујемо ип адресу:
/ip address add address=89.72.87.41/28 interface=wan disabled=no

Све одлазне конекције су усемрене маскарадом преко wan интерфејса:
/ip firewall nat chain=srcnat action=masquerade out-interface=wan

Долазне конекције на порт 80 су мапиране на ип адресу локалног сервера:
/ip firewall nat chain=dstnat action=dst-nat
\
dst-port=80 protocol=tcp to-addresses=10.10.10.2

Два сервера и рутер – вашар

Али, шта када је то потребно урадити када је потребно мапирати исти порт на два сервера? […]
[ ... види цео чланак ... ]

TP-Link TL-SG2109WEB, VLAN и Mikrotik

Скраћена веза: https://pedja.supurovic.net/veza/5148

У настојању да мало средим мрежу и шуму каблова одлучио сам да применим VLAN. За ту сврху сам узео управљиви свич TP-Link TL-SG2109WEB. Он има 8 гигабитних портова што је морало да ми буде довољно, с обзиром да су свичеви са већим бројем портова значајно скупљи.

Инсталација коју сам замислио да остварим је следећа:

Имам три интенет линка које све желом да једним каблом спојим на Микротик. Стога ћу направити три ВЛАН-а (VLAN1, VLAN2 i VLAN3) које ћу спојити у један транк (TRUNK). У Микротику ћу направити три ВЛАН интерфејса на физичком WAN интерфејсу и они ће ми служити за подешавање конекција за линкове. […]
[ ... види цео чланак ... ]

PPPoE конекција Микротик рутера као клијента

Скраћена веза: https://pedja.supurovic.net/veza/5037

PPPoE је мрежни протокол који комбинује Ethernet протокол физичке мрежне везе са PPP протоколом користећи предности оба ова протокола.

Ethernet протокол је поједностављено речено физичка мрежна конекција која се успоставља између уређаја коју су повезани ethernet каблом или на неки други начин. Таква веза је предуслов да би се могла остварити било каква комуникација.

PPP протокол је осмишљен како би се омогућило директно повезивање нека два чвора између којих постоји нека друга врста конекције. Тиме се формира привидна мрежа (VPN) која не постоји физички али постоји логички. Уређаји који су повезани у такву мрежу се виде међусовно како да су заиста физички директно повезани. […]
[ ... види цео чланак ... ]

Affiliate marketing није криминал

Скраћена веза: https://pedja.supurovic.net/veza/4871

Ових дана српска интернет заједница је узбуркана због суђења двојици власника сајта www.freebetting.net и www.kladionicar.com. Подигла се читава хајка против српског правосудног система због овог случаја. Повод су тврдње да се овим процесом у ствари зарада од провизија на Интернету доводи у питање и сврстава у кривична дела.

На почетку да разјаснимо шта је affiliate marketing. Енглески израз не показује на први поглед да се ради о класичној заради од провизија. Неко ко се бави одређеном делатношћу може да ангажује спољне сараднике који ће доводити клијентелу а заузврат ће, од сваког склопљеног посла добити одређени проценат. То је начин пословања са којим се срећемо свакодневно. […]
[ ... види цео чланак ... ]

Микротик: ограничење приступа према јачини сигнала

Скраћена веза: https://pedja.supurovic.net/veza/4673

За поуздан рад приступне тачке у бежичном умрежавању основни предуслов је да сви клијенти повезани на ту тачку имају квалитетну везу. Када постављате планску мрежу то ћете обезбедити избором одговарајуће опреме и антена за жељене линкове. Међутим, када приступна тачка служи за јавни приступ када се корисници могу повезивати повремено и нисте у могућности да им условљавате опрему коју ће да користе, потребан вам је неки начин да обезбедите контролу квалитета веза.

Микротик обезбеђује једноставан и ефикасан систем контроле приступа на основу јачине сигнала. Под претпоставком да је за добру везу најважније обезбедити добар ниво сигнала, можете приступ омогућити само корисницима који имају задовољавајући ниво сигнала. […]
[ ... види цео чланак ... ]