Где наћи старе верзије Микротика

Скраћена веза: https://pedja.supurovic.net/veza/5477

Из разноразних разлога вам може затребати нека од старијих верзија микротика. Нажалост, на микротик сајту се могу наћи само последње актуелне верзије. Старе склањају.

Тиме ваљда настоје да натерају кориснике да употребљавају смо последње верзије иако су познати по томе да  су им те верзије пуне багова и да их често објављују и без неког озбиљнијег тестирања.

Но, ако вам треба нека старија, коју користите зато што вам ради стабилно и поуздано, ево места где се налази архива свих досадашњих верзија, па бирајте:

http://mikrotik.online.ir/

 […]
[ ... види цео чланак ... ]

Микротик као PPTP сервер

Скраћена веза: https://pedja.supurovic.net/veza/5438

Често се јавља потреба да се направи симулирана интернет веза која служи као безбедна веза између две удаљене тачке које обе имају приступ Интернету. Разлози могу бити разнолики, а најчешће се ради о повећању безбедности и заштите података који иду кроз несигурно интернет окружење.

Оваква веза се назива тунелом јер има само два краја и не може се у њу ући другачије, осим на та два краја. Тунел може бити обезбеђен лозинком и шифрован. Две тачке овакву везу виде као да је стварна веза и могу је користити исто као и било коју другу интернет везу.

Пошто је све што пролази кроз тунел сигурно од приступа са стране, он се може пропустити преко Интернета и тако повезивати тачке које треба да размењују осетљиве информације. […]
[ ... види цео чланак ... ]

Умрежавање некомерцијалних бежичних мрежа у Србији

Скраћена веза: https://pedja.supurovic.net/veza/5406

У Србији постоји већи број некомерцијалних бежичних мрежа. Оне функционишу као заједнице људи који се интересују за рачунаре, умрежавање и дружење. Раде на некомерцијалном принципу, а сами чланови на добровољној основи покривају трошкове постављања приступних тачака и њиховог одржавања.

Овакве мреже се стварају у местима где постоји довољно заинтересованих људи да учествују у постављању опреме и међусобном повезивању. Међутим, с обзиром на постојање више оваквих мрежа у Србији, од самог њиховог настајања је постојала и идеја о међусобном повезивању.

Први корак је био договор између мрежа да се на одговарајући начин искористи приватни опсег ИП адреса, тако да свака мрежа користи неки део приватног опсега, али да не долази до преклапања. […]
[ ... види цео чланак ... ]

Планирање ИП адреса у мрежи

Скраћена веза: https://pedja.supurovic.net/veza/5337

Један од већих проблема са којим се суочавају администратори је планирање подмрежавања. Суштина је да сви настоје да оптимално употребе ИП адресе које су им на располагању, а за то је потребно доста планирања. ИП адресе су ограничен ресурс, па је зато неопходно што боље их употребити. Објаснићу неке принципе које примењујем када то радим.

Овај чланак се не бави основама подмрежавања. Пре него што наставите читање, препоручујем да прочитате чланке  Умрежавање – основни појмови и Умрежавање – како додељивати ИП опсеге.

Како планирати топологију мреже

Највећи проблем код планирања wireless community мреже је у ствари то што се не зна унапред њена топологија. […]
[ ... види цео чланак ... ]

Микротик скрипт: чување статистике протока у текст датотеци

Скраћена веза: https://pedja.supurovic.net/veza/5245

Ево једноставног примера који демонистрира употребу микротик скрипт језика за читање података из Simple Queue у петљи и њихов запис у текстуалну датотеку:

{

 :local mOutput ""

 :foreach mQueue in=[ /queue simple find] do={  

   :local mName [get $mQueue name]
   :local mSaveStat [:find $mName "%"] 

   :if ($mSaveStat >= 0)  do={
     :local mBytes [get $mQueue bytes]
     /queue simple reset-counters $mQueue
     :set mOutput ( $mOutput . $mName . ":" . $mBytes  . "\n")
     :put ($mOutput)
   }

 }

 /file print file=wan-stats
 /file set wan-stats.txt contents="$mOutput"

}

Кроз листу Simple Queue правила се пролази петљом foreach. За свако правило се извршава код у do блоку петље. […]
[ ... види цео чланак ... ]

Микротик: више јавних ИП на једном интерфејсу

Скраћена веза: https://pedja.supurovic.net/veza/5211

Недавно сам имао необичан случај мапирања портова за два сервера иза НАТ рутера. У локалној мрежи су подигнута два веб сервера, и требало је обезбедити да сваки од њих види са Интернета.

Са једним сервером је то лако, на мрежном интерфејсу на који долази интернет линк се подеси dst-nat порта tcp 80 ка серверу и то је готова ствар. Подешавање изгледа овако:

Интерфејсу додељујемо ип адресу:
/ip address add address=89.72.87.41/28 interface=wan disabled=no

Све одлазне конекције су усемрене маскарадом преко wan интерфејса:
/ip firewall nat chain=srcnat action=masquerade out-interface=wan

Долазне конекције на порт 80 су мапиране на ип адресу локалног сервера:
/ip firewall nat chain=dstnat action=dst-nat
\
dst-port=80 protocol=tcp to-addresses=10.10.10.2

Два сервера и рутер – вашар

Али, шта када је то потребно урадити када је потребно мапирати исти порт на два сервера? […]
[ ... види цео чланак ... ]