Gde naći stare verzije Mikrotika

Skraćena veza: https://pedja.supurovic.net/veza/5477

Iz raznoraznih razloga vam može zatrebati neka od starijih verzija mikrotika. Nažalost, na mikrotik sajtu se mogu naći samo poslednje aktuelne verzije. Stare sklanjaju.

Time valjda nastoje da nateraju korisnike da upotrebljavaju smo poslednje verzije iako su poznati po tome da  su im te verzije pune bagova i da ih često objavljuju i bez nekog ozbiljnijeg testiranja.

No, ako vam treba neka starija, koju koristite zato što vam radi stabilno i pouzdano, evo mesta gde se nalazi arhiva svih dosadašnjih verzija, pa birajte:

http://mikrotik.online.ir/

 […]
[ ... vidi ceo članak ... ]

Mikrotik kao PPTP server

Skraćena veza: https://pedja.supurovic.net/veza/5438

Često se javlja potreba da se napravi simulirana internet veza koja služi kao bezbedna veza između dve udaljene tačke koje obe imaju pristup Internetu. Razlozi mogu biti raznoliki, a najčešće se radi o povećanju bezbednosti i zaštite podataka koji idu kroz nesigurno internet okruženje.

Ovakva veza se naziva tunelom jer ima samo dva kraja i ne može se u nju ući drugačije, osim na ta dva kraja. Tunel može biti obezbeđen lozinkom i šifrovan. Dve tačke ovakvu vezu vide kao da je stvarna veza i mogu je koristiti isto kao i bilo koju drugu internet vezu.

Pošto je sve što prolazi kroz tunel sigurno od pristupa sa strane, on se može propustiti preko Interneta i tako povezivati tačke koje treba da razmenjuju osetljive informacije. […]
[ ... vidi ceo članak ... ]

Umrežavanje nekomercijalnih bežičnih mreža u Srbiji

Skraćena veza: https://pedja.supurovic.net/veza/5406

U Srbiji postoji veći broj nekomercijalnih bežičnih mreža. One funkcionišu kao zajednice ljudi koji se interesuju za računare, umrežavanje i druženje. Rade na nekomercijalnom principu, a sami članovi na dobrovoljnoj osnovi pokrivaju troškove postavljanja pristupnih tačaka i njihovog održavanja.

Ovakve mreže se stvaraju u mestima gde postoji dovoljno zainteresovanih ljudi da učestvuju u postavljanju opreme i međusobnom povezivanju. Međutim, s obzirom na postojanje više ovakvih mreža u Srbiji, od samog njihovog nastajanja je postojala i ideja o međusobnom povezivanju.

Prvi korak je bio dogovor između mreža da se na odgovarajući način iskoristi privatni opseg IP adresa, tako da svaka mreža koristi neki deo privatnog opsega, ali da ne dolazi do preklapanja. […]
[ ... vidi ceo članak ... ]

Planiranje IP adresa u mreži

Skraćena veza: https://pedja.supurovic.net/veza/5337

Jedan od većih problema sa kojim se suočavaju administratori je planiranje podmrežavanja. Suština je da svi nastoje da optimalno upotrebe IP adrese koje su im na raspolaganju, a za to je potrebno dosta planiranja. IP adrese su ograničen resurs, pa je zato neophodno što bolje ih upotrebiti. Objasniću neke principe koje primenjujem kada to radim.

Ovaj članak se ne bavi osnovama podmrežavanja. Pre nego što nastavite čitanje, preporučujem da pročitate članke  Umrežavanje – osnovni pojmovi i Umrežavanje – kako dodeljivati IP opsege.

Kako planirati topologiju mreže

Najveći problem kod planiranja wireless community mreže je u stvari to što se ne zna unapred njena topologija. […]
[ ... vidi ceo članak ... ]

Mikrotik skript: čuvanje statistike protoka u tekst datoteci

Skraćena veza: https://pedja.supurovic.net/veza/5245

Evo jednostavnog primera koji demonistrira upotrebu mikrotik skript jezika za čitanje podataka iz Simple Queue u petlji i njihov zapis u tekstualnu datoteku:

{

 :local mOutput ""

 :foreach mQueue in=[ /queue simple find] do={  

   :local mName [get $mQueue name]
   :local mSaveStat [:find $mName "%"] 

   :if ($mSaveStat >= 0)  do={
     :local mBytes [get $mQueue bytes]
     /queue simple reset-counters $mQueue
     :set mOutput ( $mOutput . $mName . ":" . $mBytes  . "\n")
     :put ($mOutput)
   }

 }

 /file print file=wan-stats
 /file set wan-stats.txt contents="$mOutput"

}

Kroz listu Simple Queue pravila se prolazi petljom foreach. Za svako pravilo se izvršava kod u do bloku petlje. […]
[ ... vidi ceo članak ... ]

Mikrotik: više javnih IP na jednom interfejsu

Skraćena veza: https://pedja.supurovic.net/veza/5211

Nedavno sam imao neobičan slučaj mapiranja portova za dva servera iza NAT rutera. U lokalnoj mreži su podignuta dva veb servera, i trebalo je obezbediti da svaki od njih vidi sa Interneta.

Sa jednim serverom je to lako, na mrežnom interfejsu na koji dolazi internet link se podesi dst-nat porta tcp 80 ka serveru i to je gotova stvar. Podešavanje izgleda ovako:

Interfejsu dodeljujemo ip adresu:
/ip address add address=89.72.87.41/28 interface=wan disabled=no

Sve odlazne konekcije su usemrene maskaradom preko wan interfejsa:
/ip firewall nat chain=srcnat action=masquerade out-interface=wan

Dolazne konekcije na port 80 su mapirane na ip adresu lokalnog servera:
/ip firewall nat chain=dstnat action=dst-nat
\
dst-port=80 protocol=tcp to-addresses=10.10.10.2

Dva servera i ruter – vašar

Ali, šta kada je to potrebno uraditi kada je potrebno mapirati isti port na dva servera? […]
[ ... vidi ceo članak ... ]