Izbornik Zatvoriti

Simplified CNC Milling Calculator

Skraćena veza: https://pedja.supurovic.net/veza/9871

Deciding what milling parameters to use can be tricky task, especially for less experienced people like me. Most of the information regarding CNC milling are related to professional equipment and may be quite detailed, hard to follow and not quite applicable to hobby machines. When you use small hobby machine, you are usually on your own. While investigated this I gathered some info that may be useful for others too, so I am sharing it.

The most simple way to deal with setting milling parameters is targeting optimal chip load. Chips are particles of material that milling tool cuts from the body of the material. […]
[ ... vidi ceo članak ... ]

Mikrotik skript: čuvanje statistike protoka u tekst datoteci

Skraćena veza: https://pedja.supurovic.net/veza/5245

Evo jednostavnog primera koji demonistrira upotrebu mikrotik skript jezika za čitanje podataka iz Simple Queue u petlji i njihov zapis u tekstualnu datoteku:

{

 :local mOutput ""

 :foreach mQueue in=[ /queue simple find] do={  

   :local mName [get $mQueue name]
   :local mSaveStat [:find $mName "%"] 

   :if ($mSaveStat >= 0)  do={
     :local mBytes [get $mQueue bytes]
     /queue simple reset-counters $mQueue
     :set mOutput ( $mOutput . $mName . ":" . $mBytes  . "\n")
     :put ($mOutput)
   }

 }

 /file print file=wan-stats
 /file set wan-stats.txt contents="$mOutput"

}

Kroz listu Simple Queue pravila se prolazi petljom foreach. Za svako pravilo se izvršava kod u do bloku petlje. […]
[ ... vidi ceo članak ... ]