Mikrotik skript: čuvanje statistike protoka u tekst datoteci

Skraćena veza: https://pedja.supurovic.net/veza/5245

Evo jednostavnog primera koji demonistrira upotrebu mikrotik skript jezika za čitanje podataka iz Simple Queue u petlji i njihov zapis u tekstualnu datoteku:

{

 :local mOutput ""

 :foreach mQueue in=[ /queue simple find] do={  

   :local mName [get $mQueue name]
   :local mSaveStat [:find $mName "%"] 

   :if ($mSaveStat >= 0)  do={
     :local mBytes [get $mQueue bytes]
     /queue simple reset-counters $mQueue
     :set mOutput ( $mOutput . $mName . ":" . $mBytes  . "\n")
     :put ($mOutput)
   }

 }

 /file print file=wan-stats
 /file set wan-stats.txt contents="$mOutput"

}

Kroz listu Simple Queue pravila se prolazi petljom foreach. Za svako pravilo se izvršava kod u do bloku petlje. […]
[ ... vidi ceo članak ... ]

Mikrotik: filtriranje konekcija po protokolima

Skraćena veza: https://pedja.supurovic.net/veza/1479

Vrlo je česta potreba da u ruteru ili zaštitnom zidu (firewall) presretnete neki određeni protokol, da biste mu, recimo, dali viši ili niži prioritet, da biste regulisali brzinu protoka ili čak taj protokol zabranili. Razloga za prepoznavanje protokola ima mnogo.

Neke protokole je lako razaznati jer koriste namenske portove, kao na primer POP3, SMTP, HTTP, SSH, FTP i slični. Za takve protokole obično je sasvim dovoljno filtrirati konekcije po poznatim portovima, primenjujući logiku da ako konekcija koristi određeni port, to znači da je to konekcija koja koristi i protokol za koji je taj port namenjen.

Nedostaci filtriranja po portovima

protokol port
FTP 20 TCP
21 TCP
SSH 22 TCP
22 UDP
Telnet 23 TCP
SMTP 25 TCP
POP3 110 TCP
DNS 53 TCP
53 UDP
DHCP 67 UDP
68 UDP
HTTP 80 TCP
NTP 123 UDP
NetBIOS 137 TCP
137 UDP
138 TCP
138 UDP
139 TCP
139 UDP
DC 411 TCP
412 TCP

Filtriranje po portovima ima i slabih strana. […]
[ ... vidi ceo članak ... ]

Osnovno o deljenju internet veze u Mikrotiku

Skraćena veza: https://pedja.supurovic.net/veza/17

Kada poželite da svoju internet vezu podelite na dva ili više računara nastaje problem. Umrežavanje i deljenje internet protoka nije baš jednostavan zadatak, ne samo zato što je potrebno neko predznanje, već i zato što je potrebna odgovarajuća oprema.

Već dugo se Mikrotik nameće kao zgodno rešenje, baš onda kada jeftini fabrički ruteri ne mofu da urade posao (mada će vas svaki prodavac uverevati da mogu), jer Mikrotik može da radi na praktično bilo kakvom starom PC računaru i tako postane prilično jeftino rešenje, ali dovoljno moćno da ga mnogi porede i sa Ciskom.

Ako ste se odlučili da upotrebite Mikrotik, nailazite na prepreku u nedostatku iskustva i znanja kako se deli Internet i niste jedini. […]
[ ... vidi ceo članak ... ]