Теме: Uncategorized | Микротик | СПАМ

Блокирање реклама у Вајберу и Скајпу на Микротик рутеру

Скраћена веза: https://pedja.supurovic.net/veza/9336

Вајбер (Viber) је у новим верзијама увео приказивање реклама. Исто радии Скајп (Skype). Као корисници тих програм ми смо у ствари постали производ. Вајбер и Скајп продају нас као медије за рекламирање.

Рекламе се приказују тако да су насртљиве и често ометају нормално коришћење програма. Нажалост, ко је већ изгради гомилу веза преко ових програма не може тек тако да прекине са њиховим коришћењем.

Решење за ово је релативно једноставно: само треба преусмерити домене које Вајбер и Скајп корсте за приказ реклама на непостојеће адресе. Једнотавност је у ствари релативна јер да би неко то подесио треба да зна шта је ДНС и како се то подешава на конкретном уређају на коме жели да блокира рекламе.

Микротик то може да поједностави. Уместо да на сваком појединачном уређају блокриате рекламе, можете их једноставно блокирати на рутеру и то ће важити за све уређаје који су у локалној мрежи. Админситратор Микротик рутер зна шта је ДНС, како ради и како се подешава и ако то уради на Микротик рутеру, тием ће решити проблем свим корисницима у својој локалној мрежи тако да они ништа не морају да подешавају на својим уређајима.

Микротик има могућност да ради као једноставан ДНС сервер. Основна намена је да кешира ДНС упите тако да локални рачунару не морају да се ослањају на ДНС сервис на Интернету већ могу да користе локални који је бржи.

Поред тога, у локани ДНС се могу уписати и статички ДНС А слогови за локалне потребе. То се обично употребљава за доделу локалних домена уређајима у локалној мрежи због веће практичности – да се не би укуцавале ИП адресе.

Међутим, ви ово можете употребити и да неки стварни домен преусмерите на другу адресу. Можете ту могућност искористити да урадите управо оно што не неопходно за блокирање реклама.

Да бисте ово искористили треба да већ имате подешен ДНС сервис на Микротик рутеру. Тиме се нећемо бавити у овом чланку јер је то већ раније објашњавано. Такође, уређаји у локалној мрежи треба да буду подешени да користе Микротик као ДНС сервер. То је део уобичајеног основног подешавања за дељење интернет конекције у мрежи.

Након што сте подесили локалну мрежу да користи локални ДНС сервис можете блокирати Вајбер и Скајп рекламе. Уђите на Микротик рутер преко терминала и укуцајте следеће:

/ip dns static
add address=127.0.0.1 name=ads.viber.com ttl=52w1d
add address=127.0.0.1 name=ads.aws.viber.com ttl=52w1d
add address=127.0.0.1 name=ads-d.viber.com ttl=52w1d
add address=127.0.0.1 name=rad.msn.com ttl=52w1d
add address=127.0.0.1 name=skype.ad.com ttl=52w1d
add address=127.0.0.1 name=skype.api.com ttl=52w1d
add address=127.0.0.1 name=apps.skype.com ttl=52w1d

И то је све. Након овог подешавања сваки пут када Viber на било ком уређају у локалној мрежи, био то рачунар, лаптоп, мобилни телефон, медија плејер или било шта друго, буде хтео да прикаже рекламе, биће онемогућен.

А шта када уређај није у локалној мрежи

Уређаји као што су мобилни телефон ипак нису сувек повезани у вашу локалну мрежу. Пошто њих нoсите са собом то значи да приступ Интернету могу да добијају и са других мрежа тако да ваше блокирање неће радити.

Најбоље је да у там случају на мобилним телефонима блокирате  ове домене, али веровероватно ће да помогне и то што на Микротик рутеру подесите TTL за ДНС слогове не неки дуг период. У примеру изнад ТТЛ је подешен на годину дана. То значи да ће мрежни уређај, када једном преузме податке о домену, да их код себе држи годину дана, па ће тако мобилни телефони и када су на другој мрежи, употребљавати ту информацију о домену коју већ имају код себе сачувану. Ипак, овако сачувана подешавања трају само док не рестартујете уређај.

Укратко
Наслов
Блокирање реклама у Вајберу и Скајпу на Микротик рутеру
Опис
Вајбер (Viber) је у новим верзијама увео приказивање реклама. Исто радии Скајп (Skype). Као корисници тих програм ми смо у ствари постали производ. Вајбер и Скајп продају нас као медије за рекламирање. Ипак, можемо их блокирати.
Аутор

2 comments to Блокирање реклама у Вајберу и Скајпу на Микротик рутеру

Leave a Reply

 

 

 

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Попуните израз тако да буде тачан: *