Teme: Uncategorized | Mikrotik | SPAM

Blokiranje reklama u Vajberu i Skajpu na Mikrotik ruteru

Skraćena veza: https://pedja.supurovic.net/veza/9336

Vajber (Viber) je u novim verzijama uveo prikazivanje reklama. Isto radii Skajp (Skype). Kao korisnici tih program mi smo u stvari postali proizvod. Vajber i Skajp prodaju nas kao medije za reklamiranje.

Reklame se prikazuju tako da su nasrtljive i često ometaju normalno korišćenje programa. Nažalost, ko je već izgradi gomilu veza preko ovih programa ne može tek tako da prekine sa njihovim korišćenjem.

Rešenje za ovo je relativno jednostavno: samo treba preusmeriti domene koje Vajber i Skajp korste za prikaz reklama na nepostojeće adrese. Jednotavnost je u stvari relativna jer da bi neko to podesio treba da zna šta je DNS i kako se to podešava na konkretnom uređaju na kome želi da blokira reklame.

Mikrotik to može da pojednostavi. Umesto da na svakom pojedinačnom uređaju blokriate reklame, možete ih jednostavno blokirati na ruteru i to će važiti za sve uređaje koji su u lokalnoj mreži. Adminsitrator Mikrotik ruter zna šta je DNS, kako radi i kako se podešava i ako to uradi na Mikrotik ruteru, tiem će rešiti problem svim korisnicima u svojoj lokalnoj mreži tako da oni ništa ne moraju da podešavaju na svojim uređajima.

Mikrotik ima mogućnost da radi kao jednostavan DNS server. Osnovna namena je da kešira DNS upite tako da lokalni računaru ne moraju da se oslanjaju na DNS servis na Internetu već mogu da koriste lokalni koji je brži.

Pored toga, u lokani DNS se mogu upisati i statički DNS A slogovi za lokalne potrebe. To se obično upotrebljava za dodelu lokalnih domena uređajima u lokalnoj mreži zbog veće praktičnosti – da se ne bi ukucavale IP adrese.

Međutim, vi ovo možete upotrebiti i da neki stvarni domen preusmerite na drugu adresu. Možete tu mogućnost iskoristiti da uradite upravo ono što ne neophodno za blokiranje reklama.

Da biste ovo iskoristili treba da već imate podešen DNS servis na Mikrotik ruteru. Time se nećemo baviti u ovom članku jer je to već ranije objašnjavano. Takođe, uređaji u lokalnoj mreži treba da budu podešeni da koriste Mikrotik kao DNS server. To je deo uobičajenog osnovnog podešavanja za deljenje internet konekcije u mreži.

Nakon što ste podesili lokalnu mrežu da koristi lokalni DNS servis možete blokirati Vajber i Skajp reklame. Uđite na Mikrotik ruter preko terminala i ukucajte sledeće:

/ip dns static
add address=127.0.0.1 name=ads.viber.com ttl=52w1d
add address=127.0.0.1 name=ads.aws.viber.com ttl=52w1d
add address=127.0.0.1 name=ads-d.viber.com ttl=52w1d
add address=127.0.0.1 name=rad.msn.com ttl=52w1d
add address=127.0.0.1 name=skype.ad.com ttl=52w1d
add address=127.0.0.1 name=skype.api.com ttl=52w1d
add address=127.0.0.1 name=apps.skype.com ttl=52w1d

I to je sve. Nakon ovog podešavanja svaki put kada Viber na bilo kom uređaju u lokalnoj mreži, bio to računar, laptop, mobilni telefon, medija plejer ili bilo šta drugo, bude hteo da prikaže reklame, biće onemogućen.

A šta kada uređaj nije u lokalnoj mreži

Uređaji kao što su mobilni telefon ipak nisu suvek povezani u vašu lokalnu mrežu. Pošto njih nosite sa sobom to znači da pristup Internetu mogu da dobijaju i sa drugih mreža tako da vaše blokiranje neće raditi.

Najbolje je da u tam slučaju na mobilnim telefonima blokirate  ove domene, ali veroverovatno će da pomogne i to što na Mikrotik ruteru podesite TTL za DNS slogove ne neki dug period. U primeru iznad TTL je podešen na godinu dana. To znači da će mrežni uređaj, kada jednom preuzme podatke o domenu, da ih kod sebe drži godinu dana, pa će tako mobilni telefoni i kada su na drugoj mreži, upotrebljavati tu informaciju o domenu koju već imaju kod sebe sačuvanu. Ipak, ovako sačuvana podešavanja traju samo dok ne restartujete uređaj.

Ukratko
Naslov
Blokiranje reklama u Vajberu i Skajpu na Mikrotik ruteru
Opis
Vajber (Viber) je u novim verzijama uveo prikazivanje reklama. Isto radii Skajp (Skype). Kao korisnici tih program mi smo u stvari postali proizvod. Vajber i Skajp prodaju nas kao medije za reklamiranje. Ipak, možemo ih blokirati.
Autor

2 comments to Blokiranje reklama u Vajberu i Skajpu na Mikrotik ruteru

Leave a Reply

 

 

 

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Popunite izraz tako da bude tačan: *