Теме: Микротик

Микротик: контрола протока (QoS) и приоритета конекција

Скраћена веза: https://pedja.supurovic.net/veza/1691

Једна од чешћих питања везаних за подешавање Микротика се односе на контролу протока. Микротик важи за једно од најјефтинијих решења за квалитетну контролу протока али није баш једноставан за подешавање.

У најједноставнијем случају употребићете Simple Queues и најчешће је то сасвим довољно. Како се користи Simple Queues можете прочитати у упутству http://wireless.uzice.net/uputstva/mikrotik-osnovno-podesavanje-deljenje-internet-konekcije/

Међутим, ако вам јепотребно иоле компликованија контрола протока, давање приоритета одређеним врстама кнекција, а ограничавање других, ту већ има много више посла и потребно је Микротик познавати много озбиљније.

На недавно одржаном МУМ, Јанис Мегис (Janis Megis) из Микротика је одржао предавање баш на ову тему којим је покрио у основним цртама углавном све што је потребно знати. Предавање је снимљено тако да га можете погледати.

Уз видео снимак послужиће вам и ПДФ са слајдовима са предавања.

Предавање само треба да вам послужи као увод, јер ћете ипак морати да прочитате још много тога да бисте овладали Микротиком на овај начин.


Поделите овај чланак са пријатељима


27 comments to Микротик: контрола протока (QoS) и приоритета конекција

  • Nedim

    Pozdrav,
    Vas odlican tekst mi je puno pomogao pri osposobljavanju PC kao mikrotik rutera. Imam pitanje. Naime, M-Tik router se na net spaja preko Access pointa na ISP. M-Tik je podesen na NAT (masquerade) i iza njega se nalaze tri PC-a. Prema Vasem uputstvu, podesio sam Simple Queue ali me zanima zasto M-Tik, kada od onih tri klijent PC-a dvojica ne koriste net (bar ne puno), usporava treci klijent PC umjesto da mu dodijeli puni (neiskoristeni) protok. Brzina interneta je 512/192 Kbps, PC-1 ima limit na 384/128 kbps i max limit na 2048 Kbps sa prioritetom na 1 a druga dva imaju po 256/80 kbps limit i max limit na 384/128 kbps sa prioritetom na 2. Srdacan pozdrav

  • Прва ствар, ако ти је брзина интернет линка 512 kbps, онда нема никакве сврхе да рачунарима у локалној мрежи ограничаваш брзину на 2048 kbps јер ту брзину нико не може дапостигне.

    max-limit не треба да буде већи од максималне брзине интернет протока која је могућа. Коме желиш да дозволиш да повуче максималан проток преко интернет линка који имаш, намести му max-limit на 512 kbps.

    Супротно томе, употреби limit-at да подесиш гарантовану брзину. Ова брзина треба да буде мања од брзине интернет линка, подешена тако да је могуће да сви корисници добију ту гарантовану брзину и када сви одједном вуку проток с аинтернет линка. У твом случају са три рачунара у локалној мрежи који деле интернет проток, то би требало да буде 170 kbps.

    Као што је у овом а и другим чланцима речено, када преоптеретиш линк, онда заборави на ограничење протока. То ради само ако постоје слободни ресурси на линку да се може радити дељење. Оног момента када рачунари који деле интернет проток теже да повуку заједно више него што интернет линк може да пружи сва правила дељења протока падају у воду.

    Погледај чланак http://wireless.uzice.net/uputstva/mikrotik-osnovno-podesavanje-deljenje-internet-konekcije/ који се овим детаљније бави.

  • Nedim

    Pozdrav,
    Veliko hvala na brzoj replici.
    Tih 2048kbps sam za PC-1 stavio jer ponekad se desi da internet link malo preskoci limit od 512kbps, vjerovatno zbog smanjenog opterecenja kod ISP-a. Iako je ne moze postici, htio sam da natjeram M-tik da, kada su druga dva PC-a ugasena, prvom dodijeli sav raspolozivi protok i da ga smanji na limit samo ukoliko se ukljuci neki od druga dva PC-a.
    Znaci, moje pitanje bi se moglo i ovako preformulisati. Ukoliko za PC-1 postavim samo CIR (limit-at) limit a MIR (max-limit) izostavim, hoce li on biti zakljucana na CIR limit bez obzira na opterecenje linka tj. hoce li mu, ukoliko je to moguce, dodijeliti kompletan protok? (tj. da posudi trenutno nekoristeni protok rezervisan za druge.)

    Drugo, kako da podesim prioritete raznim protokolima – konkretno za p2p. Htio bih da mi ne usporava bit-torrent. Mislim da mi M-Tik ogranicava broj peerova a ne znam kako da to iskljucim. Koristim bit-torrent i bitno mi je da radi max mogucom brzinom.

    Veliki pozdrav,
    Nedim

  • Као што рекох, limit-at је гарантовани проток. Микротик ће се трудити да корсинику обезбеди бар толики проток све док је то могуће. max-limit је максималан проток, Микротик ће кориснику дозвољавати највише толики проток. Ако max-limit није подешен, онда ће Микротик кориснику пружити све што може.

    Ограничења протока функционишу само док линк није преоптерећен, другим речима, Микротик ће покушавати да корсиницима обезбеди гарантовани проток све док има довољно протока да сви буду задовољени.

    Што се тиче приоритета за протоколе, јеси ли ти уопште погледао овај видео запис због кода сам написао овај чаланк. Он је одговор на твоје питање. Додуше, он одговара и на питања везана за ограничење протока, као и чланак за који сам ти оставио линк. Не очекујеш да морам да ти их препричавам?

  • Ljubek

    Imam mrežu od dvadesetak korisnika (windows Xp Workgroup) i Adsl nalog od telekoma 3 Mbit. ADSL modem je spojen na mikrotik (Pentium 3 sa Mikrotik OS 3.2 Level 5). Izlaz sa druge mrežne karte je spojen na svič i dalje do svakog računara.Sve je podešeno i radi korektno prema Vašem uputstvu:
    http://wireless.uzice.net/uputstva/m…net-konekcije/
    Zanima me ako hoću da za sebe uzmem 1Mbit protoka a za ostale da se deli na ravne časti (svi imaju pristup netu) da li komanda izgleda ovako:

    /queue simple add name=“Moj PC“ dst-address=192.168.1.11/32
    interface=wan direction=both priority=8 queue=default/default
    limit-at=32000/32000 max-limit=1000000/1000000 disabled=no
    (za moj računar)

    I za ostale:

    /queue simple add name=“ostali“ dst-address=0.0.0.0/0
    interface=wan direction=both priority=8 queue=default/default
    limit-at=32000/32000 max-limit=64000/64000 disabled=no

    Kada ovako podesim parametre dolazi do odličnog rada mreže i Interneta na svim računarima (barem sam gledao desetak njih) nekih pola sata a onda iz (meni) neobjašnjivih razloga dolazi do gušenja i potpunog prestanka rada Interneta na svim računarima???

  • На simple queue за твој рацунар стави limit-at на 1 мбит и теби ће бити гарантована брзина од 1 мбит.

    Додај још један simple queue (назови га на пример korisnici) коме ћеш ставити max-limit на 2 мегабита (боље је нешто мање) а онда за сваког корисника нови simple queue коме ћеш ставити да је simple queue који се зове korisnici родитељ (parent), тако да можеш сваком појединачно додатно да регулишеш брзину по потреби, али да сви заједно не могу прећи 2 мбита.

    Увек рачунај са тим да ограниченње протока ради само док има довољно протока за све, оног момента када корисници покушају да повуку више него што интернет линк може да да, нема гаранција да ће ограничење протока радити како треба.

  • Ljubek

    Hvala na brzom odgovoru, pokušaću kao što si rekao.
    Inače može li ovako da se po svakoj IP adresi dodijeli protok za recimo 128/64K:

    /queue simple add name=“Klijent 1-n“ target-addresses=ip_klijenta_1-n/32 dst-address=0.0.0.0/0 interface=all parent=none priority=8 queue=default/default limit-at=64000/128000 max-limit=64000/128000 burst-limit=64000/256000 burst-threshold=64000/128000 burst-time=10s/10s total-queue=default

    Pozdrav

    • Ако си то хтео – може, само смањи burst-treshold јер ће ти тако како си наместио сваких 10 секунди укључивати привремено повећање брзине. Смањи то на рецимо 100000.

  • umrezavanje racunara

    E dopada mi se clanak, bas sam se namucio oko podesavanja prvi put. Steta sto nisam tada izguglao ovo. Nadam se da ce pocetnicima biti od koristi. Pozdrav

  • Vlada

    Pozdrav pedja. Imam nekoliko pitanja.

    Posedujem neku pentium 2 i planiram da kupim mikrotik softver i da uradim sledece ako je moguce.

    E ovako sam ja zamislio.

    ADSL modem –> mikrotik(u njemu 3 LAN kartice i jedna WLAN,preko jedne lan kartice dobijam net,a preko druge dve dajem net za 2 racunara u kuci,a WLAN –> Omni antena na koju se kace ljudi oko mene)

    Zanima me da li je ovo moguce ostvariti?

    Imam neki wireless pojacivac(1000mW).Da li ce on pomoci
    da dalje bacim signal,npr za neke ljude koji su udaljeni od moje kuce 1km do 3km?

    • Може то што си замислио, само ти не требају две лан картице за по кући. Довоњна је једна а на њу закачи свич па разводи колико хоћеш.

      Што се тиче појачавача, баци га. Не треба ти, само ћеш да правиш са њим проблеме и себи и другима, а и противзаконито је њихово коришћење.

      Сви проблеми са дометом се увек и искључиво решавају антенама.

  • Vlada

    imam jos jedno pitanje.

    Da li ja smem da prodajem internet bez registrovanja „firme“?4
    Jel postoji neki zakon u vezi toga?
    Kod mene u selu ima jedna wireless mreza i svi se zale
    i ja sam dosao na ideju da im ucinim dobro,plus da neki
    dinar zaradim.Koliko znam ni ta mreza nije registrovana.

  • Да би се бавио интернет провајдингом мораш регистровати фирму одговарајуће делатности и регистровати се као интернет провајдер код РАТЕЛ-а. Без тога, довољна је само једна пријава да ти све што си уложио пропадне.

    Уз то не смеш препродавати линк који си узео од интернет провајдера без његове сагласности.

  • Vedran

    Postovani Pedja,
    Radim seminarski rad na temu „Metode kontrole toka i zagusenja na MikroTIK ruteru“. Pregledao samo detaljno Vasu stranicu i vidio sam da ste strucnjak u toj oblasti. Zelio bih Vas zamoliti da mi pomognete sta bi tacno trebao uraditi u ovoj temi i neke eventualne literature koja ima obradjenu tu temu. Asistent koji mi je davao zadatak rekao je da je naglasak na prakticnome radu.
    Hvala Vam mnogo unaprijed i srdacni pozdravi iz snijeznog Sarajeva.

    • Ух, то је прилично комплексна тема. Могу ти сдати само неке неке идеје шта треба да истражиш:

      – ограничење протока – издвојена конекција се ограничава тако да не може даоптерети линк више од дозвољеног. Проток може бити гарантован и негарантован.

      – давање различитог приоритета конекцијама – у случају загушења, конекција са већим приоритетом има предност

      – ограничавање броја конекција – уколико одређени извор има више конекција него што му је дозвољено, нове конекције му нису дозвољене

      – распршивање конекција преко више рута – између две тачке може постојати више рута, па се конекције распоређују по свима њима како би се свака појединачно растеретила

      Што се тиче литературе, једини извори су микротик упутство, микротик форум и понеки сајт са туторијалима, као што је овај мој.

  • Vedran

    A da li biste nam mogli objasniti kako napraviti prakticnu mrezu u kojoj bi mogli testirati te metode kontrole toka i zagusenja??

  • Потребан вам је један микротик као рутер на коме ћете радити подешавања. Наједан интерфејс спојте свич и неколико рачунара који ће симулирати клијенте а на друга два интерфејса би требало да доведете интернет линкове да бисте имали могућност симулације расподеле на више линкова.

    Ако немате вишелинкова онда можете употребити још један микротик на коме ћете два интерфејса спојити са тестним микротиком па ће он да вам симулира интернет ликове. на овај микротик на трећи интерфејс ставите један рачунар који ће симулирати интернет.

    За тестирање користите програм Bandwidth Test. Поставите га на све рачунаре и њиме можете симулирати различите брзине протока као оптерећење. Немам идеју са чим бисте могли симулирати велики број једновремених конекција. можда ћете морати да напишете неки програм који ће вам то радити.

  • Steva

    pozdrav
    mene interesuje kako da zabranim pristum svima koji adresu kucaju rucno
    odnosno da dozvolim samo onima koji dobiju adresu od DHCP servera i to ako je moguce samo nda kad ja kazem u DHCP LEASES da je adresa static i zavedem je u simple queue ili tako nekako, da niko ne moze da se nakaci na lan bez dozvole.

  • На мрежном интерејсу поресиш АРП reply-only а у ДХЦП серверу укључиш Add ARP For Leases.

  • Steva

    za rucno dodavanje adresa je ok
    jos samo kako da resim da nemaju pristup netu ni adrese koje je DHCp server dodelio i jos su dinamicke odnosno da ga ja vidim u DHCP LEASES
    i zavedem ga kao static i tek onda da ima pristum netu ili tako nekako
    🙂

  • Најједноставније је да групишеш ИП адресе, на пример статичне додљуј у опсегу 192.168.1.100 до 192.168.1.200 а динамичке од 192.168.1.200 до 192.168.1.50. У фајерволу ћеш тада моћи да за сваку групу подесиш жељена правила.

  • Daky

    Pozdrav! Hteo bih da pitam kako bih mogao da od vise mikrotika i antena tj predajnika napravim bridg da sve to ide na jedan glavni mikrotik i tamo da limitiram protok,a ne na svakom posebno,znaci svi korisnici da budu na jednom mikrotiku (routerboard 1200), a ostali sistemi tj vise mikrotika na vise mesta da rade kao link tj samo da prenesu konekciju korisnika do glavnog mikrotika u glavnom mikrotiku je ukljucen opticki kabal, ako je to moguce, i kako? 🙂

    Pozz!

    • Зависи шта хоћешп да урадиш.

      Ако ти је циљ да контролишеш проток који корсиници праве преко интернет линка онда то ионако све терба да радиш на рутеру који је директно повезан на интернет линк а свеједно је каква је конфигурација локалне мреже.

      Ако желиш да ограничиш протоке и унутар мреже, дакле, између корисника, онда треба да направиш да се корисници повезују преко ВПН (обично PPPoE) и тако можеш на једном месту да им отвараш налога и подешаваш колико ко може да има протока.

      Најлакше јесте да све спојиш у бридж али је ти и лошије решење. Боље је да користиш радијус сервер.

  • Daky

    hvala na odg! A kazi mi kako mogu da izbegnem opadanje protoka kroz tri bazne stanice na trecoj baznoj stanici 3 puta opao protok,nije bridzovano nego natovano.. mikrotikovi su natovani.. ? 🙂

  • Steva

    pozdrav
    imam problem u Simple Queues, nece da meri trenutni protok kad je Download/upload na unlimited, odnosno cim stavim neki limit on pocne da meri protok saobracaja, gde gresim kako da to resim.
    hvala

Leave a Reply

 

 

 

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Попуните израз тако да буде тачан: *